码疯窝

Elementary OS Freya 安装Docker不支持的解决方案

2015/07/26 00:20:58    分类: 技术随笔    0人评论 次浏览

Docker 是支持 Ubuntu 的,而且Elementary Freya是基于Ubuntu 14.04 LTS的。
所以理论上应该是可以安装成功的。执行以下命令安装Docker却提示错误。

curl -sSL https://get.docker.com/ | sh

snapshot1

查看安装代码才发现,在安装时有检测系统的发行版信息。
解决方案一
修改/etc/lsb-release文件为Ubuntu Trusty的版本信息, 安装完成后再修改回Elementary Freya的版本信息, 理论可行, 并未测试。

解决方案二(推荐)
修改安装脚本,亲测可行。详细步骤如下:

wget https://get.docker.com/ -O /tmp/install.sh
chmod +x /tmp/install.sh
vim /tmp/install.sh

如图如示加入高亮部分代码。
screenshot2

lsb_dist='ubuntu'
dist_version='trusty'

安装成功后:
snapshot3

继续查看有关 技术随笔的文章

0个访客评论